top of page

Group

Public·128 members

Matlab 2012b License File 28 ##VERIFIED##



I spoke with an IT person from my client's company who wrestled with the issue "a while ago." He said that after several attempts to fix the issue by Mathworks support, they concluded the above. Having the server reread the license file does not help. I am guessing that this is a little-used feature that doesn't justify the cost to fix.




matlab 2012b license file 28



This got rid of the error, but I still have a problem launching Matlab. Each time I launch it (by typing "matlab" in terminal), the Mathworks software activation window pops up. I provide the path to the licence file, it appears to activate successfully (no errors), but then Matlab doesn't launch. If I try to run it again, the same thing happens.


Way too old thread but viewed 4523 times and active 16 days ago so still relevant I guess. Here is how you solve it. In my case the folder "/.matlab/R2015a_licenses/" did not exist. though "/.matlab" did. So I created R2015a_licenses. Now the problem is this folder was accessible only to root. So the activation application could not write the required file. So change the permission of this folder using "sudo chmod 777 R2015a_licenses". Now run matlab normally(no sudo). It should take you to the activation client. otherwise run the activation client manually(no sudo), it is called "activate_matlab.sh" in the bin folder. follow the steps and let it detect the user-name and do not change it. when it exits without error you are done with the licence part. Now there could be another problem that your matlab freezes just after the opening window and doesn't go any further. Take a look at this. "Go to the ".matlab/" directory in the users home directory. Rename the directory named after the version of MATLAB you are using to have _old at the end. If there is a folder with "_licenses" in the name, DO NOT rename that folder" kind of worked. By kind of I mean matlab complained that it cant write preferences in "/.matlab". So I changed the permission for that folder by "chmod" and then it worked.


About

Welcome to the group! You can connect with other members, ge...
Group Page: Groups_SingleGroup
bottom of page